『入门』(递归专题)n个数的最大公约数

This commit is contained in:
James 2020-04-30 18:22:50 +08:00
parent 21eb082bc3
commit 777981363e
8 changed files with 70 additions and 0 deletions

View File

@ -0,0 +1,18 @@
# 1668 『入门』递归专题n个数的最大公约数
[问题描述]
  输入n个正整数求它们的最大公约数。
[输入格式]
  第一行一个整数n表示数的个数。(1 < n <= 101)
  第二行n个整数相互之间空格隔开。
[输出格式]
  一行为N个整数的最大公约数。
[输入样例]
2
48 54
[输出样例]
6

View File

@ -0,0 +1 @@
#

View File

@ -0,0 +1,27 @@
#include <iostream>
using namespace std;
int find(int yi,int er){
//cout<<yi<<" "<<er<<endl;
if(yi%er==0){
return er;
}else{
return find(er,yi%er);
}
}
int main()
{
int n,last;
cin>>n;
cin>>last;
for(int i=1;i<n;i++){
int now;
cin>>now;
if(last<now){
int cg=last;
last=now;
now=cg;
}
last=find(last,now);
}
cout<<last;
}

BIN
1668_zuidagongyue/main.exe Normal file

Binary file not shown.

View File

@ -0,0 +1,2 @@
2
48 54

View File

@ -0,0 +1,2 @@
101
100 300 500 700 900 1100 1300 1500 1700 1900 2100 2300 2500 2700 2900 3100 3300 3500 3700 3900 4100 4300 4500 4700 4900 5100 5300 5500 5700 5900 6100 6300 6500 6700 6900 7100 7300 7500 7700 7900 8100 8300 8500 8700 8900 9100 9300 9500 9700 9900 10100 10300 10500 10700 10900 11100 11300 11500 11700 11900 12100 12300 12500 12700 12900 13100 13300 13500 13700 13900 14100 14300 14500 14700 14900 15100 15300 15500 15700 15900 16100 16300 16500 16700 16900 17100 17300 17500 17700 17900 18100 18300 18500 18700 18900 19100 19300 19500 19700 19900 20100

View File

@ -0,0 +1,2 @@
3
42 14 49

View File

@ -0,0 +1,18 @@
## z:\Chao\src\1668_zuidagongyue\test\in.txt
2020/04/30 ÖÜËÄ 18:21:43.78
6
-----------------------------------------------
Process exited after 140 ms with return value 0
## z:\Chao\src\1668_zuidagongyue\test\in2.txt
2020/04/30 ÖÜËÄ 18:21:43.78
100
-----------------------------------------------
Process exited after 80 ms with return value 0
## z:\Chao\src\1668_zuidagongyue\test\in3.txt
2020/04/30 ÖÜËÄ 18:21:43.78
7
-----------------------------------------------
Process exited after 80 ms with return value 0